近期我們有打算將網站的 PHP 版本升級成 PHP7,只不過遇到最麻煩的問題就是可能會因為網站中的程式語言的版本不同而產生臭蟲 (BUG) 的狀況,這是我們最需要避免的。

對於現在的 WordPress系統來說,他已經完整支援 PHP7 了。所以我們要檢查的重點就要放在擴充外掛與佈景主題上面。然而要一個一個去人工檢查實在太費力,所以我們有使用了一套擴充外掛「PHP Compatibility Checker」來自動偵測所有的外掛與主題是否能完整支援 PHP7。

PHP Compatibility Checker 外掛資訊


  • 外掛名稱:PHP Compatibility Checker
  • 支援語系:英文
  • 外掛下載:點我下載

Step 1.

從 WordPress 管理後台內的「安裝外掛」功能中搜尋「PHP Compatibility Checker」,請將下圖中的這一套擴充軟體安裝並啟用至網站中。


Step 2.

緊接著,從 WordPress 管理後台中的「工具」選項內就會出現了「PHP Compatibility」的選項,進入後就是測試用的面板了。
從「PHP Version」中選擇你要進行測試的 PHP 版本,「Plugin/Theme Status」選擇「Scan all plugins and themes」,即可點選 Scan Site 開始掃描。


Step 4.

當網站被掃描完後同一個頁面下方就會顯示出每一個主題與外掛的 PHP 相容性,只要是綠色勾勾的話就是沒問題。
看來如果我的網站切換過去 PHP7 的話是沒問題的!

你也可以下載這個報表存成文本以方便給老闆或廠商做備案。